Automatically Upgrade your Mikrotik router firmware & OS.

If your mikrotik router times out when checking for Your mikrotik router firmware & OS upgrade.

Automatically Upgrade your Mikrotik router firmware & OS with the provided Script below

how to check for upgrade for your mikrotik router constantly.

/system scheduler

add interval=1w name=”Package upgrade” on-event=\

    “system package update install” policy=\

    ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon \

    start-date=oct/10/2018 start-time=17:13:19

add interval=1w name=”Routerboard Upgrade” on-event=”:global Var1\r\

    \n:global Var2\r\

    \n:set Var1 \”\$[/system package get system version]\”\r\

    \n:set Var2 \”\$[/system routerboard get current-firmware]\”\r\

    \n:if (\$Var1>\$Var2) do={/system routerboard upgrade;\r\

    \n/system reboot;\r\

    \n}” policy=\

    ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon \

    start-date=oct/10/2018 start-time=07:16:30

One thought on “Automatically Upgrade your Mikrotik router firmware & OS.

  • October 14, 2018 at 5:49 pm
    Permalink

    nice article sir now i m understand how to upgrade

    Reply

Leave a Reply

Your email address will not be published. Required fields are marked *